[Support request] GFPC 3.2.5 always requiring update

If you have purchased a product, please enter the email address that you used to register at time of purchase.